본문으로 바로가기

폰갭(Cordova) 설치

category IT/프로그래밍 2015.12.23 05:50




1. node.js 설치

https://nodejs.org/en/ 에서 v5.3.0 Stable 다운로드 후 설치


2. cordova 설치

npm install –g cordova


3. 프로젝트 생성

cordova create myproject kr.cuenet.myproject MyProjectTitle


4. 플랫폼 추가

cd myproject

cordova platform add android


5. ANDROID_HOME 환경변수 추가

set ANDROID_HOME=<Android SDK 경로>


6. Cordova Build

cordova build android

 

※ 구버전인 경우 : cordova platform android update


7. 안드로이드 시뮬레이터 실행

cordova emulate android


※ 안드로이드 시뮬레이터에서 생성한 프로젝트를 바로 실행할 경우

cordova run android


※ 웹브라우저에서 테스트할 경우 

cordova platform add browser

cordova run browser


저작자 표시 비영리 변경 금지
신고
크리에이티브 커먼즈 라이선스
Creative Commons License

댓글을 달아 주세요

  1. 개발은힘들군. 신고">2016.01.20 10:11 신고

    4번에서 명령어를 치면 This plugin is only applicable for versions of cordova-android greater than 4.0
    IF you have a previous platform version, you do *not* need this plugin since the whitelist will be built in. 이런 오류가 나는데 어떻게 해결하면 좋을까요..

    • BlogIcon 이금성 신고">2016.02.01 16:00 신고

      에러 내용만 보면 해당 플러그인이 4.0 이상에서만 작동한다고 하네요~ 버전을 업그레이드 해보시기 바랍니다.

티스토리 툴바